Sunday, August 20, 2006

gentoo + arch not set..mor0n...

--------------------------error start-----------------------------------
gentoob0x yomuds # emerge -av dsniff

These are the packages that I would merge, in order:

!!! ARCH is not set... Are you missing the /etc/make.profile symlink?
!!! Is the symlink correct? Is your portage tree complete?

-------------------------error end-------------------------------------

have you guys having this problem after emerging with --sync option. if you had, here is a solution to overcome this problem.

shell> ls -al /etc/make.profile.
check where is the softlink of /etc/make.profile. if it's pointing to the correct file (/usr/portage/profiles/default-linux/x86/2006.0), then it is shoudn't be the problem. but if it not, you need to re-create the softlink file. remove the current /etc/make.profile first.

shell>rm /etc/make.profile
shell>ln -s /usr/portage/profiles/default-linux/x86/2006.0 /etc/make.profile

hope this help.:D.gentoo always had bad surprises for you guys.btw, gentoo roxx!!.:D

Friday, August 18, 2006

vmware player & qemu : not a perfect match..:P

aha, i;m glad for using qemu instead of vmware workstations. anyways, all sort of this is just a metter of personal taste. working in linux env, certain things can be done easily with CLI tools.:D. a few ppls said that to change setting on qemu is quite difficult like to change size of rams, cdrom file, network setting and bla bla bla. if you're using qemu frequently, don't forget the combination keys of "ctrl+alt+2". this combination will help and allow you to manipulate qemu me, it's so easy to run qemu than vmware player. at least on qemu i didn't need to recompile my new kernel modules.hahaha. just another execuse. anyways, i just done configured and installed a freebsd image using qemu. but, since my fren need to run this image for vmware player, i reformated the image format to vmdk. example on qemu to create vmdk image format:

shell> qemu-img create -f vmdk Freebsd.iso 10G

i was thinking at that memont that there are couldn't be any problems when i boot the image using vmware player. i was wrong, dudes. vmware player only recognized a configuration file with extenstion *.vmx. what?. then, i'm clueless. how could i create that *.vmx file when i didn't even have vmware workstations(no pirated software please). lucky me to know that file *.vmx is only text base file.:D.kewl. then the next thing is to googling around about vmware player config file. i was stumbled to this site. woww, greate efforts man. thanx noobacide.:D. noobacide's tool is a tool to allow you to manually configure *.vmx file to fit your need.:D. here is my *.vmx config file:

config.version = "8"
virtualHW.version = "3"

MemAllowAutoScaleDown = "FALSE"
MemTrimRate = "-1"

uuid.location = "56 4d 5c cc 3d 4a 43 29-55 89 5c 28 1e 7e 06 58"
uuid.bios = "56 4d 5c cc 3d 4a 43 29-55 89 5c 28 1e 7e 06 58"

uuid.action = "create"
checkpoint.vmState = ""

displayName = "FreeBSD 6.0"
guestOS = "freeBSD"
memsize = "256"

ethernet0.present = "TRUE"
ethernet0.connectionType = "bridged"
ethernet0.addressType = "generated"
ethernet0.generatedAddress = "00:0c:29:7e:06:58"
ethernet0.generatedAddressOffset = "0"

usb.present = "TRUE"
usb.generic.autoconnect = "TRUE"

sound.present = "TRUE"
sound.virtualdev = "es1371"

scsi0.present = "TRUE"
scsi0.virtualdev = "buslogic"

scsi0:0.present = "FALSE"

scsi0:1.present = "FALSE"

floppy0.present = "TRUE"
floppy0.fileName = "A"
floppy0.startConnected = "FALSE"

ide0:0.present = "TRUE"
ide0:0.fileName = "FreeBSD-6.0.iso"
ide0:0.deviceType = "disk"
ide0:0.mode = ""
ide0:0.redo = ""
ide0:0.writeThrough = "TRUE"
ide0:0.startConnected = "TRUE"

ide0:1.present = "TRUE"
ide0:1.fileName = "cdrom"
ide0:1.deviceType = "cdrom-raw"
ide0:1.autodetect = "FALSE"
ide0:1.startConnected = "FALSE"

ide1:0.present = "FALSE"

ide1:1.present = "FALSE"


aha, it's quite a lot of works need to done before you can 'freely' using your new, im not gonna use vmware player as long as qemu is still in my hand.:P..nuff said.

p/s: why i;m always got problems when compiling a brand new kernel?.even with 'make oldconfig' from working kernel.:(.my bads.